CVE-2026-42271 — LiteLLM — Fixed in 1.83.7

High8.8 Published on May 8, 2026

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Fixed versions

Choose the version for your installed product and release branch.

ProductFixed versions
LiteLLM1.83.7

Versions stated in the NVD description

Actively exploited

  • In the CISA exploited-vulnerabilities catalogue since Jun 8, 2026
  • US federal agencies must remediate it by Jun 22, 2026 (BOD 22-01)
  • First attack observed 31 days after disclosure
  • Confirmed by sensors, not only by reports
  • Used in ransomware campaigns

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Source: CISA KEV · Oct 29, 2026 Oct 28, 2026 Oct 27, 2026 Oct 26, 2026 Oct 25, 2026 Oct 24, 2026

CVSS score8.8 / 10CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness type (CWE)CWE-77, CWE-78, CWE-78
Vendorsredhat, litellm

Affected products

VendorsProductVersions
litellmlitellm< 1.83.7
redhatopenshift ai< 2.25.8

Related articles

This product uses the NVD API but is not endorsed or certified by the NVD.

CVE database